I've had an issue with Ghost Touches since I bought my device. I'd be typing, and suddenly my cursor would be in the wrong spot. I did some experiments, I thought maybe it wasn't actually the touch screen at all, maybe it was the track pad? So I disabled both. It still happened! So, I did a lot of Googling, tried a lot of things, and finally found the solution. It's a problem with how Windows manages the screen on reboot.

Right Click > Start Button
Left Click > Power Options
Left Click > Chose what the power buttons do
Left Click > Change settings that are currently unavailable
Scroll down to "Shutdown settings"
Uncheck "Turn on fast startup" <-- This is the option causing the problem.
Left Click > Start Button
Left Click > Power
Left Click > Shut Down

Once your device is completely off, reboot it.
No more ghost clicks.

I believe that Asus has this set this way when you buy the device. But if you change it, or, if you reinstall windows from scratch (what I did) then you'll end up with the default windows setting which causes the problem.