Results 1 to 6 of 6
  1. #1
    Ratchet
    Member #
    18864
    Join Date
    Dec 2011
    Location
    Lakeville, Minnesota
    Posts
    162
    Liked
    9 times

    Prime won't turn on...now what?

    I long press the power button for 10 secs....all I get is a quick buzz. I long press power and volume up for 10 seconds....and again, I get a quick buzz, but nothing happens. I've tried to do a reset using a paperclip and that didn't do anything.

    Do I have a brick in my hands or is there a way to fix this?

    Thanks-

  2. #2
    Supporting Member
    Supporting Member

    Member #
    590
    Join Date
    May 2011
    Location
    U.S/CA/OC
    Tablet
    TF101
    Posts
    3,375
    Liked
    471 times
    My old 101 needs a longer press once in awhile.

    Try holding the power button in for 30 or so seconds.

  3. #3
    Ratchet
    Member #
    18864
    Join Date
    Dec 2011
    Location
    Lakeville, Minnesota
    Posts
    162
    Liked
    9 times
    Nope. Tried holding down the power button for 30-40 seconds. It gives me a quick vibration at 10 seconds, but nothing after that. Any other suggestions?

  4. #4
    Supporting Member
    Supporting Member

    Member #
    853
    Join Date
    May 2011
    Location
    Sacramento Ca
    Tablet
    TF700
    Posts
    3,388
    Liked
    689 times
    Trying to think what else to do. Have you tried plugging it in? That starts up my Transformer every time unless the battery is dead. When that happens there will be a black screen then finally a battery symbol will appear that shows it is now charging. Then it will take a bit more charging before it will boot up.

  5. #5
    Ratchet
    Member #
    18864
    Join Date
    Dec 2011
    Location
    Lakeville, Minnesota
    Posts
    162
    Liked
    9 times
    I've plugged it in using two different charger....the orginal charger and the charger for my TF101 (assuming they are the same). No difference. Nothing starts. Besides the quick buzz I get after 10 seconds, it doesnt' do a thing: no Asus logo, just a black screen.

  6. #6
    Supporting Member
    Supporting Member

    Member #
    853
    Join Date
    May 2011
    Location
    Sacramento Ca
    Tablet
    TF700
    Posts
    3,388
    Liked
    689 times
    Quote Originally Posted by mrteeth View Post
    I've plugged it in using two different charger....the orginal charger and the charger for my TF101 (assuming they are the same). No difference. Nothing starts. Besides the quick buzz I get after 10 seconds, it doesnt' do a thing: no Asus logo, just a black screen.
    Yes the chargers are compatible and I'm assuming both of your chargers are working. If your Prime battery is totally dead it could take 3 to 5 minutes for the battery symbol on the screen to appear. Then even a few more minutes after that before it can boot up. Other than that I'm stumped and you may have to RMA your tablet unless someone else can trouble shoot something.

 

 

Remove Ads

Sponsored Links

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  

Similar Threads

  1. Prime won't turn on
    By gmn in forum Transformer Prime Help
    Replies: 7
    Last Post: 02-25-2013, 08:50 PM
  2. [SOLVED] Transformer Prime Won't Turn On
    By billbowers in forum Asus Transformer (TF101) Help
    Replies: 1
    Last Post: 07-02-2012, 02:05 PM
  3. Help! My Prime won't turn on!
    By Betsyfru in forum Transformer Prime Help
    Replies: 5
    Last Post: 01-05-2012, 06:56 PM
  4. Prime will not turn on
    By vphshockey in forum Transformer Prime General Discussions
    Replies: 6
    Last Post: 12-31-2011, 12:45 PM

Search tags for this page

asus transformer prime won't power up

Click on a term to search for related topics.
Powered by vBulletin® Version 4.2.3
Copyright © 2019 vBulletin Solutions, Inc. All rights reserved.
Search Engine Optimization by vBSEO 3.6.1
All times are GMT -6. The time now is 04:33 PM.