Results 1 to 8 of 8
Like Tree1Likes
  • 1 Post By stumpypete

Thread: docking external drive into the USB port on TF300

  1. #1
    Soundwave
    Member #
    56845
    Join Date
    May 2013
    Tablet
    TF300T
    Posts
    1
    Liked
    0 times

    docking external drive into the USB port on TF300

    Hello all.
    Well, I thought I was pretty good at computer related issues, but the Android 4.1 (JellyBean) OS is baffeling me.
    I have an Asus TF300T B2, and tried to connect an external drive (WD My Passport) to the USB port on the attachable keyboard/pad; the local file management software doesn't recognize it. Then I tried about 5 different USB sticks, no avail. I even reformatted a USB 2 stick to FAT32. Nothing.
    It seems you have to go to the My Storage and 'removable', but there's nothing. I inserted a microSD card into the main tablet, and the software immediately recognized it (even though it was empty). But nothing for the USB port.
    What am I doing wrong?

  2. #2
    Super Moderator & Spaminator
    Supporting Member

    Member #
    50369
    Join Date
    Dec 2012
    Location
    Europe and Japan
    Tablet
    TF700
    Posts
    824
    Liked
    255 times
    It doesn't sound like you're doing anything wrong. I don't have a 300, but my 201 and 700 work fine with all the USB sticks I have tried. Not sure about that WD drive though, it depends a bit on how much current it needs.
    Hopefully someone can pop in and provide some insight.

    -Tor

  3. #3
    Guide Guru & Forum Administrator
    Supporting Member

    Member #
    12453
    Join Date
    Oct 2011
    Location
    Devon, UK
    Tablet
    Other - Chromebook
    Posts
    14,013
    Liked
    2827 times
    Welcome to the forum

    As Tor says, you are doing nothing wrong...

    So I'd suggest either a Factory Reset or a warranty repair are in your immediate future...

    Sorry not be of more help...

    PLEASE Search for existing threads before posting a new one. Thanks.

    Your opinion matters. But should you disagree - please try not to be disagreeable

    Forum guide - here ~~ T100 FAQs - here ~~ Cold boot - here

    Adobe Flash Player & Browser Guide here

    Master Help Guide - here ~~ FAQ malware - here ~~ FAQ e-reading - here
    Mobile OS devices personal pantheon...
    ANDROID: Doogee DG310; SGS; Huawei Y300; Motoroloa Xoom 2ME; Razr; Defy Mini; CnM Touchpad II;
    Asus TF101; Lenovo A1; Samsung Tab 2 7.0
    APPLE: iPhone 4s; iPhone 5c; iPhone 6; iPhone 7; iPad 3; iPad Mini 2; iPad Air 2 64gb
    CHROMEBOOK: HP 14-Q010sa Celeron 14 Inch 4GB 16GB Chromebook - White.

  4. #4
    Soundwave
    Member #
    44165
    Join Date
    Sep 2012
    Tablet
    TF300T
    Posts
    6
    Liked
    0 times
    Quote Originally Posted by munrau View Post
    Hello all.
    Well, I thought I was pretty good at computer related issues, but the Android 4.1 (JellyBean) OS is baffeling me.
    I have an Asus TF300T B2, and tried to connect an external drive (WD My Passport) to the USB port on the attachable keyboard/pad; the local file management software doesn't recognize it. Then I tried about 5 different USB sticks, no avail. I even reformatted a USB 2 stick to FAT32. Nothing.
    It seems you have to go to the My Storage and 'removable', but there's nothing. I inserted a microSD card into the main tablet, and the software immediately recognized it (even though it was empty). But nothing for the USB port.
    What am I doing wrong?
    Stupid question, but have you tried restarting the tablet with the keyboard dock connected and then attach the HDD once it has rebooted.
    I know for a fact that you can get the WD My Passport to work as i have one and use it all the time with my tablet.
    The only time i have a problem with it, and all USB connected devices is if the tablet is on and i then connect the dock, sometimes the USB port just wont work, if this happens i just restart the tablet whilst the dock is connected and then it works fine.
    Like i said i use this combination all the time to transfer/copy files and even watch films off the hard drive.

  5. #5
    Guide Guru & Forum Administrator
    Supporting Member

    Member #
    12453
    Join Date
    Oct 2011
    Location
    Devon, UK
    Tablet
    Other - Chromebook
    Posts
    14,013
    Liked
    2827 times
    Quote Originally Posted by savill View Post
    Stupid question, but have you tried restarting the tablet with the keyboard dock connected and then attach the HDD once it has rebooted.
    I know for a fact that you can get the WD My Passport to work as i have one and use it all the time with my tablet.
    The only time i have a problem with it, and all USB connected devices is if the tablet is on and i then connect the dock, sometimes the USB port just wont work, if this happens i just restart the tablet whilst the dock is connected and then it works fine.
    Like i said i use this combination all the time to transfer/copy files and even watch films off the hard drive.
    That isn't a stupid suggestion at all

    But the problem isn't just with his WD, but any and every flash drive connected to the USB port, so it may well be a hardware issue in his dock...

    PLEASE Search for existing threads before posting a new one. Thanks.

    Your opinion matters. But should you disagree - please try not to be disagreeable

    Forum guide - here ~~ T100 FAQs - here ~~ Cold boot - here

    Adobe Flash Player & Browser Guide here

    Master Help Guide - here ~~ FAQ malware - here ~~ FAQ e-reading - here
    Mobile OS devices personal pantheon...
    ANDROID: Doogee DG310; SGS; Huawei Y300; Motoroloa Xoom 2ME; Razr; Defy Mini; CnM Touchpad II;
    Asus TF101; Lenovo A1; Samsung Tab 2 7.0
    APPLE: iPhone 4s; iPhone 5c; iPhone 6; iPhone 7; iPad 3; iPad Mini 2; iPad Air 2 64gb
    CHROMEBOOK: HP 14-Q010sa Celeron 14 Inch 4GB 16GB Chromebook - White.

  6. #6
    Jazz
    Member #
    36963
    Join Date
    May 2012
    Tablet
    TF300
    Posts
    53
    Liked
    12 times
    I have the same problem. If I connect the tablet to the dock, and then plug into USB it does not recognise either stick or HDD (and also the SD card in the dock). If I attach tablet to dock and then cold boot, then it recognises the USB HDD or USB Stick. Clearly a bug in firmware that needs ironed out. However it then seems to work fine after that, so anyone encountering this problem should just do a cold boot with the dock attached to overcome it in the short term. The issue seems to come and go over time, but never been able to deduce what actually causes it, I just know that a cold boot solves it (at least for me)
    Swipe likes this.

  7. #7
    Asus USA Social Media Team
    Member #
    35389
    Join Date
    May 2012
    Location
    Fremont, CA
    Tablet
    Uncategorised
    Posts
    842
    Liked
    154 times
    Quote Originally Posted by munrau View Post
    Hello all.
    Well, I thought I was pretty good at computer related issues, but the Android 4.1 (JellyBean) OS is baffeling me.
    I have an Asus TF300T B2, and tried to connect an external drive (WD My Passport) to the USB port on the attachable keyboard/pad; the local file management software doesn't recognize it. Then I tried about 5 different USB sticks, no avail. I even reformatted a USB 2 stick to FAT32. Nothing.
    It seems you have to go to the My Storage and 'removable', but there's nothing. I inserted a microSD card into the main tablet, and the software immediately recognized it (even though it was empty). But nothing for the USB port.
    What am I doing wrong?
    It actually might be the port that's bad. Have you tried connecting a peripheral, like a USB mouse to see if it works? If nothing works at all, and a series of cold-boots, or even a factory reset don't work, I would contact support.
    Asus USA is a social support channel for North American purchasers. UK users requiring warranty support should contact their retailer. For other geographic locations, please check your product documentation or the Asus website for your locality and follow the support section instructions.




    Transformer Forums is a privately owned "user to user" forum and is not affiliated with ASUSTeK Computer Inc in any way.

  8. #8
    Jazz
    Member #
    36963
    Join Date
    May 2012
    Tablet
    TF300
    Posts
    53
    Liked
    12 times
    Quote Originally Posted by Asus_USA View Post
    It actually might be the port that's bad. Have you tried connecting a peripheral, like a USB mouse to see if it works? If nothing works at all, and a series of cold-boots, or even a factory reset don't work, I would contact support.
    THe fact that mine corrects itself with a cold boot suggests a firmware issue not hardware. Especially as it worked fine with ALL peripherals prior to Jellybean.

 

 

Remove Ads

Sponsored Links

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  

Similar Threads

  1. External CD/DVD drive
    By Glencraig in forum Asus Transformer (TF101) Accessories
    Replies: 5
    Last Post: 01-06-2015, 09:14 PM
  2. Can i use my TF300 as an external hard drive?
    By snafubaby in forum Transformer Pad 300 Help
    Replies: 6
    Last Post: 12-10-2012, 06:31 PM
  3. External BD drive
    By Spillner in forum Asus Video
    Replies: 8
    Last Post: 09-18-2012, 10:10 AM
  4. USB port to play external DVD drive?
    By Paladin in forum Transformer Prime General Discussions
    Replies: 40
    Last Post: 12-15-2011, 02:32 AM
  5. usb 3 external drive
    By Stephen in forum Asus Transformer (TF101) General Discussions
    Replies: 3
    Last Post: 07-24-2011, 11:14 AM
Powered by vBulletin® Version 4.2.3
Copyright © 2022 vBulletin Solutions, Inc. All rights reserved.
Search Engine Optimization by vBSEO 3.6.1
All times are GMT -6. The time now is 05:04 PM.