Results 1 to 7 of 7
  1. #1
    Soundwave
    Member #
    49224
    Join Date
    Dec 2012
    Tablet
    TF300T
    Posts
    4
    Liked
    0 times

    Brand new Asus TF300T wont turn on? (literally 5 minutes opened)

    Hey everyone-

    So after some browsing on the forums it seems as if this is some common problem, but Ill ask again as I have been through HELL and back returning and purchasing tablets after finally deciding to buy a NEW Asus Transformer (rather than pre-owned).

    I have literally JUST opened this box and turned the tablet on. It wont turn on. I read forums and it needs to be charged for a bit. Ok no problem.

    Im using the USB chord and charger that Asus put in the box. I got this Asus tablet at GAME STOP (if that is relevant info).

    There is no indication at all that this tablet is charging. No light or anything? I made sure that the USB chord "clicked" into the plug, and into the tablet. Seems like there is no problem there.

    Shouldnt there be some indication that this is charging? I just returned my Motorola Xoom today to purchase this and I would be so disappointed if i had to return this too

  2. #2

  3. #3
    Supporting Member
    Supporting Member

    Member #
    1793
    Join Date
    Jun 2011
    Location
    Vancouver Canada
    Tablet
    TF Book T102HA
    Posts
    5,903
    Liked
    1225 times
    Welcome to the forum. I've moved your thread to the TF300 help section. Someone with a 300 should be able to help you so hang tight. You could look through the Battery Use Guide which describes charging these tablets and you can search within the thread for TF300 posts. ( Use the Search Thread option).

  4. #4
    Soundwave
    Member #
    49224
    Join Date
    Dec 2012
    Tablet
    TF300T
    Posts
    4
    Liked
    0 times
    Quote Originally Posted by leeshor View Post
    Welcome to the forum

    Check out this thread. Should help solve your problems. http://www.transformerforums.com/for...arge-boot.html
    OMG weird!

    I plugged it into my laptop and it turned on automatically. It didnt indicate it was charging however. While it was on I plugged it into the wall charger and now its on and happily charging.

    There is no light indication of it however. Is that normal?

  5. #5
    Transformer Forums Legend
    Supporting Member

    Member #
    5624
    Join Date
    Jul 2011
    Location
    Norcross, GA
    Tablet
    TF700
    Posts
    11,748
    Liked
    1818 times
    If it's plugged into the wall charger you should see a light on the power button. But at least it sounds like it woke up.

  6. #6
    Soundwave
    Member #
    49224
    Join Date
    Dec 2012
    Tablet
    TF300T
    Posts
    4
    Liked
    0 times
    Quote Originally Posted by leeshor View Post
    If it's plugged into the wall charger you should see a light on the power button. But at least it sounds like it woke up.
    Awesome! Ok everything seems in order now. Charging at 46%
    Its giving me updates for what Im assuming is Jelly Bean. Going to update it now with my fingers crossed.
    Is there any reason why a new Asus tablet would not get Jelly Bean? Cute little robot guy is loading right now...

  7. #7
    Soundwave
    Member #
    49224
    Join Date
    Dec 2012
    Tablet
    TF300T
    Posts
    4
    Liked
    0 times
    Quote Originally Posted by Swipe View Post
    Welcome to the forum. I've moved your thread to the TF300 help section. Someone with a 300 should be able to help you so hang tight. You could look through the Battery Use Guide which describes charging these tablets and you can search within the thread for TF300 posts. ( Use the Search Thread option).
    Thank you for moving the thread to the appropriate location <3! My bad

 

 

Remove Ads

Sponsored Links

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  

Similar Threads

  1. Replies: 6
    Last Post: 07-19-2012, 01:39 PM
  2. Replies: 0
    Last Post: 07-16-2012, 09:04 AM
  3. Wi Fi wont turn on
    By RD90 in forum Transformer Prime Help
    Replies: 6
    Last Post: 05-26-2012, 09:34 AM
  4. Prime Wont turn on
    By coolbomb in forum Transformer Prime Help
    Replies: 7
    Last Post: 01-04-2012, 03:21 AM
  5. brand new eee pad wont turn on
    By retnox in forum Asus Transformer (TF101) Help
    Replies: 10
    Last Post: 09-21-2011, 06:16 PM

Search tags for this page

asus tablet not turning on

,

asus tablet wont turn on

,
asus transformers brand new
,
brand new asus laptop won't turn on
,
brand new asus laptop wont turn on
,

brand new asus tablet wont turn on

,
brand new tablet wont charge
,
brand new tablet wont turn on
,
how to turn on asus tablet
,
my new asus tablet wont turn on
,

new asus tablet wont turn on

,
new asus transformer wont turn on
Click on a term to search for related topics.
Powered by vBulletin® Version 4.2.3
Copyright © 2019 vBulletin Solutions, Inc. All rights reserved.
Search Engine Optimization by vBSEO 3.6.1
All times are GMT -6. The time now is 11:19 AM.