Results 1 to 3 of 3
  1. #1
    Soundwave
    Member #
    88244
    Join Date
    Dec 2015
    Location
    India
    Tablet
    Vivo Tab
    Posts
    1
    Liked
    0 times

    Touch Not working for ASUS VivoTab 8 (M81C)

    Hello All,

    In Oct. 2015, I purchased one ASUS VivoTab 8 (M81C) from Amazon US. This windows based tab is very good. I upgraded Windows 8.1 - 32 bit to Windows 10. Everything worked fine. In Windows 10 drains battery very fast. The battery backup was reduced to almost 50% as compared to Windows 8.1.

    I forgot to make restore disk and also deleted the old windows folder. I re-installed the Windows 8.1 - 32 bit with Bing along with all the drivers listed on Asus website.

    Right now the screen is not rotating and touch is not working. In device manager I see 2 un-known devices. In property it says something related to I2C controller.

    This device is purchased from North America, The current location is India. Not getting the local warranty from Asus.
    Windows 10 works well but I don't want to use it as it drains battery very fast.

    I request you to suggest a working solution. There are few tricks posted on various sites but those are too technical for me. Still I tried Cold booting, formatting, intel driver updated utility etc. but not working.

    Regards,

  2. #2
    Guide Guru & Forum Administrator
    Supporting Member

    Member #
    12453
    Join Date
    Oct 2011
    Location
    Devon, UK
    Tablet
    Other - Chromebook
    Posts
    14,013
    Liked
    2826 times
    Welcome to the forum

    Try reinstalling Windows 10 again. If that gets it working, you may then be able to roll back again.

    PLEASE Search for existing threads before posting a new one. Thanks.

    Your opinion matters. But should you disagree - please try not to be disagreeable

    Forum guide - here ~~ T100 FAQs - here ~~ Cold boot - here

    Adobe Flash Player & Browser Guide here

    Master Help Guide - here ~~ FAQ malware - here ~~ FAQ e-reading - here
    Mobile OS devices personal pantheon...
    ANDROID: Doogee DG310; SGS; Huawei Y300; Motoroloa Xoom 2ME; Razr; Defy Mini; CnM Touchpad II;
    Asus TF101; Lenovo A1; Samsung Tab 2 7.0
    APPLE: iPhone 4s; iPhone 5c; iPhone 6; iPhone 7; iPad 3; iPad Mini 2; iPad Air 2 64gb
    CHROMEBOOK: HP 14-Q010sa Celeron 14 Inch 4GB 16GB Chromebook - White.

  3. #3
    Rescue Squad
    Supporting Member

    Member #
    41525
    Join Date
    Jul 2012
    Tablet
    VivoTab Note 8
    Posts
    981
    Liked
    233 times
    Quote Originally Posted by janner43 View Post
    Welcome to the forum

    Try reinstalling Windows 10 again. If that gets it working, you may then be able to roll back again.
    Unless that version of W10 came from Asus I doubt it would fix the driver issue... but...

    Quote Originally Posted by funfeast View Post
    ...along with all the drivers listed on Asus website.
    So you installed all of the following?

    ASUS Live Update, Goodix Touchpanel, ATK Package, Audio Driver, SOC Driver Package, ASUS WinFlash, TXEI, Invensense GPS Driver, Broadcom GPS Driver, Broadcom Bluetooth driver, and Broadcom Wireless LAN Driver...

    And did you make sure to install the ATK and SoC drivers first, before any of the others? Since those are needed for the OS to properly recognize the hardware to then install the other drivers... and then check for updates for it to then find any other drivers from the MS database?

    It's odd you had a battery drain issue with W10... My dad has the same Vivo Tab 8 tablet upgraded to W10 and has no such issue. So may be a sign of something else not working properly or incorrectly set up. Things like driver conflicts or having the wrong driver installed have been known to cause battery drain issues. Something as simple as a WiFi driver issue can prevent the system from properly entering connected standby mode, etc.

 

 

Remove Ads

Sponsored Links

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  

Similar Threads

  1. [ SOLVED] new Asus t100 touch screen not working.
    By kedesh in forum Asus Transformer Book T100 Help
    Replies: 13
    Last Post: 04-20-2014, 05:56 PM
  2. ASUS VivoTab RT Dock Keyboard stops working
    By jg123 in forum ASUS Vivo Help
    Replies: 2
    Last Post: 11-24-2013, 04:58 AM
  3. ASUS VivoTab TF810C Keyboard Dock Battery Not Working
    By henryx7 in forum ASUS Vivo Help
    Replies: 2
    Last Post: 10-22-2013, 03:16 AM
  4. Touch screen not working..No touch Panel firmware version in settings
    By hellboyds in forum Transformer Prime Help
    Replies: 5
    Last Post: 08-31-2013, 09:44 AM

Search tags for this page

all drivers for asus vivotab 8 m81c

,
are all asus vivotab drivers in the soc
,
asus note 8 touchscren driver
,
asus vivo note 8 touch not working
,
asus vivotab 8 m81c touchscreen not working
,

asus vivotab 8 touch stops working

,
asus vivotab note 8 - touch pad turns off after sleep
,

asus vivotab note 8 touch screen driver

,

asus vivotab note 8 touch screen not working

,
no touchscreen m81c
,
registry fix asus vivo tab 8 touch screen
,

vivotab note 8 touch screen stops working

Click on a term to search for related topics.

Tags for this Thread

Powered by vBulletin® Version 4.2.3
Copyright © 2020 vBulletin Solutions, Inc. All rights reserved.
Search Engine Optimization by vBSEO 3.6.1
All times are GMT -6. The time now is 01:45 AM.