Hi there-Last resort before I throw this thing out the window.
I had been having trouble with my 12c HID on my Asus vivo note 8 Windows 8.1 and had tried to resolve it a number of times: Plug and play to auto/Unchecked "Allow windows to turn off to save power", and uninstalled a number of times but each time "Error 10". No touch but I could still use the stylus.
I decided to run a Windows update but this time, the screen has completely locked. No touch, no stylus. I think the HID devices have tanked. I tried hooking up a usb mouse but the screen doesn't register at all. All I have is my welcome screen, the battery and wifi signal. I tried switching on and off three times but of course, the advanced option/restart computer requires the ability to select and I can't do that as the screen won't register any touch at all, not even when I hook up the mouse.
This is stupidly, my second Vivo note 8 since 2015 as I loved the stylus and the micro usb has already begun to degrade which was how my other one died last year in September.
Feeling very foolish.
Any ideas?

Thanks,
BG