Page 2 of 2 FirstFirst 1 2
Results 11 to 11 of 11
Like Tree2Likes

Thread: Impossible to get OTA 2.2.33.138

  1. #11
    Soundwave
    Member #
    90232
    Join Date
    May 2016
    Tablet
    TF103
    Posts
    2
    Liked
    3 times

    Quote Originally Posted by Andrew_b View Post
    thanks for welcome !
    the procedure:
    1) download stock firmware from asus site (WW_V2.2.33.101 in my case)
    2) perform a first unzip to obtain UL-K010-WW-2.2.33.101-user.zip
    3) I work with embedded linux at work for many years, I can't live without bash shell. install SSH server, I used SSHDroid for example. With the linux shell we can fully control what happen (system logs are great !)
    Now if you try to rename the filename UL-K010-WW-2.2.33.101-user.zip to UL-K010-WW-2.2.33.138-user.zip and copy it to microSD, the new firmware is detected and we can start update procedure.
    but when the system rebot in recovery mode the process fail due a revision check (101 is less than 135 in my case). Now logs... the check is performed by controlling "ro.build.asus.version" variable.
    I try to change the file /system/build.prop (the only text file with this variable) but nothing;101 is always less than 135. Obviously this environment var is stored on recovery partition filesystem.
    So we need to overwrite this partition with those present on UL-K010-WW-2.2.33.101-user.zip.
    It is not possible to overwrite recovery from recovey itself. we need to do that when the tablet is running android.
    before that just to be sure, to be in no doubt, I overwrited my 135 kernel with the 101, but might not even be necessary.
    to do that, execute "fastboot flash boot boot.img" (boot.img from UL-K010-WW-2.2.33.101-user.zip) from recovery with USB cable PC connection.
    extract recovery directory from UL-K010-WW-2.2.33.101-user.zip to a directory of the tablet, for example tmp.
    now when logged with SSH shell execute the /tmp/recovery/etc/install-recovery.sh script.... the recovery partition is now replaced with the older one.
    4) rename UL-K010-WW-2.2.33.101-user.zip UL-K010-WW-2.2.33.138-user.zip; copy to microSD and the update procedure now ends without error.
    5) perform wipe cache and wipe data !
    to manually execute all OTA updates from 101 to 138 read patates post at [Q] Asus Transformer Pad TF103C Tablet - Roo… - Pg. 6 | Android Development and Hacking | XDA Forums
    I hope I was helpful.
    for any questions ask..
    PS: why no official GOTA notify with stock 101 firmware ? I don't understand.. after first OTA failure (138 in my case) no notify anymore.
    This also worked for me. My tablet wouldn't boot - it would freeze at the ASUS logo - so my procedure was slightly different.

    I extracted the files under /recovery from the latest official Asus KitKat firmware UL-K010-WW-2_2_33_144-user.zip. 1st I had to boot into droidboot/fastboot mode (Vol up+Power for 3 seconds until the screen turns on). Then I had to connect the tablet to usb/laptop, use the Intel Recovery IntelAndroid-FBRL-07-24-2015/launcher.bat, select any TWRM or CWM option, then T2 (T2/T3/T4 all work) - this puts the device into ADB mode. The screen will go blank but ADB commands will work. From here I did the adb push and adb shell to chmod +x the files. Note I also had to adb push recovery-from-boot.p /system/ to overwrite the system one, as install-recovery.sh looks for it under /system/. Upon executing (adb shell) /tmp/recovery/etc/install-recovery.sh, it successfully updated my droidboot/recovery to v144, and I was able to access Recovery again (from droidboot, select Recovery .. once the dead android appears on the screen, hold vol+&vol- for 3 seconds.. you may have to try holding down +/- quite a few times before you get into the recovery mode menu).

    Intel recovery link: Intel Android Devices Root / Temp Recovery S… | Android Development and Hacking
    Last edited by aslezak; 05-16-2016 at 11:46 AM.

 

 
Page 2 of 2 FirstFirst 1 2

Remove Ads

Sponsored Links

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  

Similar Threads

  1. [ SOLVED ] Impossible to use gmail account, Help
    By aniemotion in forum Asus MeMO Pad Smart (10") Help
    Replies: 10
    Last Post: 07-20-2013, 08:12 PM
  2. Can an app shut down the transformer (for power saving) or impossible?
    By Christina in forum Asus Transformer (TF101) FAQ
    Replies: 4
    Last Post: 01-14-2012, 02:15 PM
  3. Market Searching impossible
    By smoki in forum Asus Transformer (TF101) Help
    Replies: 5
    Last Post: 10-20-2011, 04:14 PM

Search tags for this page

2.2.33.138 asus
,
asus dlcdcnet fota tf103
,
asus k010 stock android#q
,
asus k010 ww-2.2.33.136
,

firmware 2.2.33.138 asus tf103c...

,

gota fota

,
how to install one 3g dongle on a tf103 wifi only.
,
k010 asus update ota
,
root asus k010 ww-2.2.33.101
,
tf103 delete unwanted
,
where to download 2.2.33.135 firmware
,
ww-2.2.33.138
Click on a term to search for related topics.
Powered by vBulletin® Version 4.2.3
Copyright © 2020 vBulletin Solutions, Inc. All rights reserved.
Search Engine Optimization by vBSEO 3.6.1
All times are GMT -6. The time now is 12:42 PM.