Hello,

I have a Transformer Book TX300 CA. It ran smoothly for the first few months, even after the Windows 8.1 upgrade.
Than, about a month ago, as I connected a USB device, problems arose. At first, both USB ports disappeared, shortly after, the built-in HD ( in the keyboard ), half an hour later the trackpad, and finally also the keyboard. All that was left functioning was the tablet ( and the Micro SD card reader ). Tried several things, but could not do a system restore ( as the restore partition was in the HD ). Finallly I had to do a Windows clean install. After weeks of trying, almost everything is functioning, except for the USB ports, and the HD.

What I tried:

I tried disabling XHCI support ( also enabling, or the " auto " setting ) in the UEFI.
Tried this method: Windows 8 and Intel USB 3.0 Host Controllers | Plugable
Tried uninstalling drivers, tried uninstalling software. I emailed Asus, little support, the only thing they could advise me was a system restore, or apply for a repair. As I bought the Transformer in Europe, and live in Africa, this is not an option.

Please help????

Thanks!