Hello everyone.

I searched the forum for a thread similar to mine and I found some, but unfortunately none of them helped me, so I decided to start a new thread.

I just bought a used T300L from a friend. I know the specific device and I have used it frequently with the previous owner since he bought it. I know it worked like a charm, apart from a strange problem that presented itself from time to time (about 3 times in 1 year), so I bought it anyway... Randomly the transformer wouldn't boot up. We used to solve this by leaving it to charge overnight and the morning after everything was all right.

I used it for abouth a month with almost no problem. Just one time it didn't boot and I tried the "overnight charging" and it worked fine.

Then one day it stopped booting for good.

The starting conditions for the tests I've done were:

  • Tablet is unplugged from the power source
  • Tablet battery fully charged
  • Keyboard battery fully charged
  • USB cable connected from the tablet USB port to the keyboard charging port (you'll see why)



These are the symptoms:

  • When I press the Power Button, the tablet vibrates briefly but the screen is completely black.
  • If the keyboard is connected via the docking bay, I can see that after turning the tablet on the charging light on the keyboard turns on too.
  • If I press the Power Button for a longer time, I suppose the tablet turns off (the charging light on the keyboard turns off).
  • If I try to enter the BIOS via [Volume down]+[Power On] I still get a brief vibration, the black screen and the same said lights behaviour.
  • It has to be noted that, after "turning on" the tablet, even if the keyboard "senses" that the tablet is on (the keyboard charging led is on), pressing Caps Lock won't turn on the corresponding indicator.


I obviously tried leaving it charging for a night: nothing changed.

I also tried turning it "on" and "draining" the battery (I left the keyboard connected and I suppose that when the charging led of the keyboard turns off, the tablet battery is empty), then fully recharging it. No solution there.

I'm open to suggestions...

Thank you in advance!