If you want to be able to boot from external media you need to disable secure boot.

Here is how to do it...

Quote Originally Posted by Asus_USA View Post
You are able to Disable secure boot by doing the following:

1. Enter the BIOS setup menu by pressing and holding F2 key when powering on.
2. Switch to "Boot" and set “Launch CSM” to Enabled.
3. Switch to "Security" and set "Secure Boot Control" to Disabled.
4. Press F10 to save and exit.
5. Press and hold ESC key to launch boot menu when the notebook restarts.