Results 1 to 7 of 7
  1. #1
    Supporting Member
    Supporting Member

    Member #
    64427
    Join Date
    Jan 2014
    Tablet
    Too lazy to choose
    Posts
    1,249
    Liked
    291 times

    [ SOLVED ] windows photo viewer crashing micro SD card only

    I am totally stumped here. I've tried everything I can think of. Windows photo viewer is suddenly crashing anytime I try to copy, cut or delete a file from the photo library, but ONLY if it is pointing at something on the micro SD card slot. If I put/add a folder from c:\, it works fine. Only within C though. If I try to copy something from D: to C: in photo viewer, it thinks about it a second and crashes to start. Same thing from C to D or D to D.

    I've tried resetting my libraries, afc /scannow, rebooting and maybe more.

    Any ideas?

  2. #2
    Ratchet
    Member #
    65880
    Join Date
    Feb 2014
    Tablet
    TF Book T100TA
    Posts
    192
    Liked
    28 times
    Quote Originally Posted by azazel1024 View Post
    I am totally stumped here. I've tried everything I can think of. Windows photo viewer is suddenly crashing anytime I try to copy, cut or delete a file from the photo library, but ONLY if it is pointing at something on the micro SD card slot. If I put/add a folder from c:\, it works fine. Only within C though. If I try to copy something from D: to C: in photo viewer, it thinks about it a second and crashes to start. Same thing from C to D or D to D.

    I've tried resetting my libraries, afc /scannow, rebooting and maybe more.

    Any ideas?
    chkdsk your SD. It might be corrupted.

  3. #3
    Supporting Member
    Supporting Member

    Member #
    64427
    Join Date
    Jan 2014
    Tablet
    Too lazy to choose
    Posts
    1,249
    Liked
    291 times
    I'll do that. Sadly I didn't have enough room for restore points so only the previous one is there (when I installed a PDF virtual print driver 2 days ago), but it is currently restoring to that point, just to check.

    It does work fine reading and writing to the card through file explorer though.

    I'll also try a refresh. I probably won't go to a full system restore as wayyyyy too much of a pain to redo everything when I can always just move my photo library to the C:\ drive. It isn't that big, but it is annoying if/that I can't use the microSD for some crazy reason.

    I really wish there was a way to roll back app updates so I can see if the most recent one to Photo Viewer is what messed things up (IIRC, that was maybe 1-2 weeks ago and I haven't tried copy/cutting/deleting/renaming any files since then till last night, but no idea how long that update was waiting for install. I usually only check every 4-6 weeks on app updates).

  4. #4
    Supporting Member
    Supporting Member

    Member #
    64427
    Join Date
    Jan 2014
    Tablet
    Too lazy to choose
    Posts
    1,249
    Liked
    291 times
    No reported errors from chkdsk.

    Oddly, as one further step before a refresh I copied the card contents to C:\ and then formatted the card from exfat to NTFS. Just on a lark. It now works.

    So oddly it looks like the photos app just decided it didn't like exfat anymore for some reason. That or possibly some bad registry entries for the mico SD card that formatting it removed. I had noticed no matter what I tried, windows always would show "read only" for all folders on the card. File explorer and robocopy had no issues with this, but maybe it was a contributing factor to photos app not wanting to do anything other than view images on the card.

  5. #5
    Supporting Member
    Supporting Member

    Member #
    1793
    Join Date
    Jun 2011
    Location
    Vancouver Canada
    Tablet
    TF Book T102HA
    Posts
    5,903
    Liked
    1225 times
    Hi. I marked this as solved... you can't "uninstall" the latest update to Photo Viewer? On Android we seem to have that option. But glad it's working for you now.


  6. #6
    Ratchet
    Member #
    65880
    Join Date
    Feb 2014
    Tablet
    TF Book T100TA
    Posts
    192
    Liked
    28 times
    Quote Originally Posted by azazel1024 View Post
    No reported errors from chkdsk.

    Oddly, as one further step before a refresh I copied the card contents to C:\ and then formatted the card from exfat to NTFS. Just on a lark. It now works.

    So oddly it looks like the photos app just decided it didn't like exfat anymore for some reason. That or possibly some bad registry entries for the mico SD card that formatting it removed. I had noticed no matter what I tried, windows always would show "read only" for all folders on the card. File explorer and robocopy had no issues with this, but maybe it was a contributing factor to photos app not wanting to do anything other than view images on the card.
    I have seen this happening also with NTSF formatted disks multiple times lately. It suspect some driver or BIOS issue lurking....

  7. #7
    Supporting Member
    Supporting Member

    Member #
    64427
    Join Date
    Jan 2014
    Tablet
    Too lazy to choose
    Posts
    1,249
    Liked
    291 times
    Hmmm yeah.

    I did several hours of searching and, no, sadly Windows 8/8.1 does not support rolling back an update. Also since it is a "core" app, you can't uninstall it and reinstall it. I did find a way to use powershell to uninstall it, but I couldn't find anything on reinstalling it then...which I didn't want to put myself in a situation where it was uninstalled and then gone.

    Also, EddieZ...not making me feel better. Sigh. I will chalk it up to possibly a registry issue. What I really should have tried was a different micro SD card to see if it had the same issue (I have a 4GB in my Nook simple touch). Hopefully this won't reoccur, but I do kind of suspect it was an issue with the last update with the photos app some how messed with application permissions to the "drive", which was resolved by formatting.

 

 

Remove Ads

Sponsored Links

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  

Similar Threads

  1. Photo viewer app?
    By davidsmartin in forum Asus Transformer Book T100 Apps
    Replies: 8
    Last Post: 01-13-2014, 02:12 PM
  2. Windows photo viewer yellow tint in Transformer Book
    By andreszm08 in forum Transformer Windows Devices General Discussion
    Replies: 0
    Last Post: 08-12-2013, 07:05 AM
  3. [SOLVED]Micro SD Card shows incorrect content on PC Windows Explorer
    By morrig47 in forum Asus Transformer (TF101) Help
    Replies: 9
    Last Post: 07-06-2012, 10:57 AM
  4. [Solved] Unable to read micro sd card
    By lamxing in forum Transformer Pad 300 Help
    Replies: 7
    Last Post: 06-26-2012, 03:09 AM

Search tags for this page

asus t100 photo viewer stopped working

,

how to install a photo viewer in a micro card

,

micro sd card crashes when copying files to asus t100

,

photo browser asus always crashes

Click on a term to search for related topics.
Powered by vBulletin® Version 4.2.3
Copyright © 2020 vBulletin Solutions, Inc. All rights reserved.
Search Engine Optimization by vBSEO 3.6.1
All times are GMT -6. The time now is 06:46 PM.