Results 1 to 2 of 2
  1. #1
    Soundwave
    Member #
    89709
    Join Date
    Mar 2016
    Tablet
    TF Book T100 Chi
    Posts
    3
    Liked
    0 times

    T100chi doesn't turn on, doesn't charge.

    Hi all!
    My t100chi stopped working. I've left it some days ago in my room and it was working. Today I took it and it doesn't charge and it doesn't turn on.
    I suspect the battery run out of charge completely and it can't charge for that reason (my room was cold in these days, I wasn't there).
    Even though in my invoice has written I have 36 months warranty, the shop I bought it just closed and the official assistance didn't repair it in warranty because they say I have only 24 months so...
    I want try to repair it by myself. How can I do?
    Please help.

    Thank you very much and merry christmas

  2. #2
    Soundwave
    Member #
    68025
    Join Date
    Mar 2014
    Tablet
    TF Book T100 Chi
    Posts
    10
    Liked
    1 times
    There is a couple things to try....
    1. push power button down for about 20 secs and see if it starts.
    2. try reseting…..I THINK THAT IS PUSH POWER BUTTON AND VOLUME DOWN BUTTON, BUT THAT MIGHT get you into bios screen, but then, at least it started.
    3. Make sure the charger is asus charger and the cable is not broken. Most of the time the cable fails because we are running 2 amps or more charging and charge cable fails.....
    4. If items above still doesn't work, then it might be the micro usb charge port is bad. Then it will have to be diassembled and micro usb port or charge board assembly needs to be replaced......problem is that removing the screen usually results in a cracked screen.....good luck

 

 

Remove Ads

Sponsored Links

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  

Similar Threads

  1. T200 doesn't show any image/doesn't boot after connecting to an external screen
    By Laurapintas in forum Asus Transformer Book T200 Help
    Replies: 4
    Last Post: 09-08-2016, 10:12 PM
  2. TF101 doesn't charge
    By jkaszynski in forum Asus Transformer (TF101) Help
    Replies: 13
    Last Post: 12-27-2012, 10:41 PM
  3. Replies: 6
    Last Post: 09-17-2012, 03:33 AM
  4. What to do if wi-fi doesn't turn on????
    By odin23 in forum Asus Transformer (TF101) Help
    Replies: 2
    Last Post: 05-12-2012, 03:36 AM
  5. Battery doesn't charge
    By Silent_Insanity in forum Asus Transformer (TF101) Help
    Replies: 3
    Last Post: 04-14-2012, 11:10 AM
Powered by vBulletin® Version 4.2.3
Copyright © 2019 vBulletin Solutions, Inc. All rights reserved.
Search Engine Optimization by vBSEO 3.6.1
All times are GMT -6. The time now is 08:24 PM.